Cannot launch Java Workstation after applying a Hotfix to APM

book

Article ID: 76599

calendar_today

Updated On:

Products

APP PERF MANAGEMENT CA Application Performance Management Agent (APM / Wily / Introscope) CUSTOMER EXPERIENCE MANAGER INTROSCOPE

Issue/Introduction

After applying a hotfix to the EM, the Webstart workstation fails to start with the Java error "JAR resources in JNLP file are not signed by the same certificate."

Cause

This is caused when the Hotfix jars and the original jars are signed with different certificates.

Environment

Release:
Component: APMISP

Resolution

To get the workstation working immediately, undo any updated workstation jars on the EM to the original version. To do this, find any new jar files in the <EM_HOME>\product\workstation\plugins folder, and replace them with the backed up files in the hotfix folder (eg hotfix\10.7.0-HF01\product\workstation\plugins).

For a long term solution:
-If this was downloaded from the support site, check and see if a newer build is available for download, and apply it. It should contain updated jar files to resolve the signing issue with the workstation. If not, open an issue with Support.
-If this was provided by CA Support, open a new issue with Support to get an updated version of the hotfix.