Inaccurate Global Collection list in CABI reports
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Inaccurate Global Collection list in CABI reports

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Article ID: 76531

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When pulling up lists of Global Collections within various Group reports in CABI, we are seeing the list of GC's is not complete. Some GC's appear to be missing from the list. In addition, when we run Availability reports on individual devices, it may show the device is down when we see it is up. 

Environment

Version: Any
Component: CABI/SRM

Cause

There are various reasons why reporting data may not be complete, from database transaction issues to sync issues, and event processing delays due to system resources, size of the databases, amount of events to process, etc. However, many times inaccurate data can be resolved by performing some restarts and resync reporting data. 

Resolution

If you are seeing inaccurate Global Collections lists, first check in Spectrum Report Manager (SRM) database that the list of GC's is correct. 

- Log into the SRM system as the suer that owns the SRM installation
- If on Windows, start a bash shell by running "bash -login"
- cd to the $SPECROOT/mysql/bin directory and enter the following command to log into mysql

 ./mysql --defaults-file=../my-spectrum.cnf -uroot -p<PASSWD> reporting

- Enter the following command at the mysql prompt:

SELECT * FROM globalcollection;

- Review the list of GCs and check if any are missing from the list

If the list in MySQL is inaccurate, you can check OneClick Tomcat log for any polling errors. MySQL logs for transaction issues, and check your landscape Archive Manager logs for any processing/polling errors. You may also want to open a case with Support to investigate further

If the list is accurate, then the issue may be CABI is not pulling the data correctly. In this case, it can help to perform service restarts and reload content from OneClick to CABI

1. Restart mysql the SRM system
- Log into the SRM system as the user that owns the SRM installation
- If on Windows, start a bash shell by running "bash -login"
- cd to the $SPECROOT/bin directory
- Enter the following command to shutdown mysql

./cmdC localhost 2 MYSQL MYSQL.OUT

- Enter the following command to start mysql:

 ./launchinstdbapp localhost MYSQL y MYSQL.OUT

2. Restart tomcat on the SRM system
- Log into the SRM system as the user that owns the SRM installation
- If on Windows, start a bash shell by running "bash -login"
- cd to the $SPECROOT/tomcat/bin directory
- Enter the following command to shutdown tomcat:

./stopTomcat.sh

- Enter the following command to start tomcat:

./startTomcat.sh

3. Restart CABI processes
- Log into the CABI system as the root user or su/sudo su to the root user
- cd the the <CABI_HOME> directory
- Enter the following command to shutdown the CABI processes:

./stopServers.sh

- Enter the following command to start the CABI processes:

./startServers.sh

 

If you still see the issue after performing the above steps, please open a case with Spectrum Support.