Checksum issue not caused by checksum problem in Software Delivery

book

Article ID: 76527

calendar_today

Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

In trace: "Error checking package CRC: Package checksum error detected." when pushing a staged package to endpoints. The package does have the "Checksum control of the package consistency" checked. The package was staged to all scalability servers, but only deploys correctly from the 2008R2 servers and not the 2012 servers. Software Delivery job error SDM228429 is seen on deployments via Windows 2012 scalability servers where the application tried to deploy from.

Cause

There are two possible library types (Or methods of connecting to and obtaining the software package access): Network Share (NOS) or NOS-LESS (Package download to local source). When the agent is able to connect and work via NOS or network share, the job succeeds. When it has to download locally, the job fails with the CRC error under certain conditions (not a problem generically but can be in this case). The inability to transfer the package via the NOS-LESS can cause a misleading error message due to the actual problem which is the lack of SDLIBRARY$ / MSILIB shares present on the Scalability Server (SS).

Environment

Windows, can happen on ANY windows version supported by ITCM / ITCA (Client Automation)

Resolution

All that needs to be done to resolve this issue is to run the following two commands on the Scalability Server. No restart of CAF nor reboot is needed:

sd_sscmd addshare sdlibrary
sd_sscmd addshare msilib

 

Additional Information

This can be executed manually, via SD package, batch file, or Asset Management script job.