Checksum issue not caused by checksum problem in Software Delivery
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Article ID: 76527
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Updated On:
Products
CA Automation Suite for Data Centers - Configuration AutomationCA Client Automation - Asset ManagementCA Client Automation - IT Client ManagerCA Client AutomationCA Client Automation - Remote ControlCA Client Automation - Asset IntelligenceCA Client Automation - Desktop Migration ManagerCA Client Automation - Patch Manager
Issue/Introduction
In trace: "Error checking package CRC: Package checksum error detected." when pushing a staged package to endpoints. The package does have the "Checksum control of the package consistency" checked. The package was staged to all scalability servers, but only deploys correctly from the 2008R2 servers and not the 2012 servers. Software Delivery job error SDM228429 is seen on deployments via Windows 2012 scalability servers where the application tried to deploy from.
Cause
There are two possible library types (Or methods of connecting to and obtaining the software package access): Network Share (NOS) or NOS-LESS (Package download to local source). When the agent is able to connect and work via NOS or network share, the job succeeds. When it has to download locally, the job fails with the CRC error under certain conditions (not a problem generically but can be in this case). The inability to transfer the package via the NOS-LESS can cause a misleading error message due to the actual problem which is the lack of SDLIBRARY$ / MSILIB shares present on the Scalability Server (SS).
Environment
Windows, can happen on ANY windows version supported by ITCM / ITCA (Client Automation)
Resolution
All that needs to be done to resolve this issue is to run the following two commands on the Scalability Server. No restart of CAF nor reboot is needed: