Error when installing CA Service Catalog R17.1.

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Article ID: 76515

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Updated On:

Products

CA Service Catalog CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When the installation has reached the "importing Content Pack" stage. You get a popup message error "error Importing Content Packs" .

Cause

Problematic situation is occurring because of the lack of required heap space during the content pack import…

Environment

Windows 2012

Resolution

* Open the file ‘contentpack.bat’
Located under USMHOME\scripts, USMHOME refers to CA Service Catalog install path …in case.
If you launch the installer afresh, you must locate the same file under the installer media, under the similar folder structure

* Now, locate the following line 
SET JAVA_OPTS=%JAVA_OPTS% -DEiamTraceLevel=WARNING -Xms1024m -Xmx2048m -Dfile.encoding=utf-8 -noverify 
And now, you may update it as follows: 
SET JAVA_OPTS=%JAVA_OPTS% -DEiamTraceLevel=WARNING -Xms1024m -Xmx4096m -Dfile.encoding=utf-8 -noverify 

* Save the above changes. 
* Now, resume the installation. 

If you still face the same problem, you may try increasing the -Xmx parameter appropriately, and then resume the installation. 
 

Additional Information

The information in this article has been included in our product documentation. You can find further details here:

https://docops.ca.com/ca-service-management/17-1/en/troubleshooting/troubleshooting-ca-service-catalog/install-or-upgrade-issues/ca-service-catalog-fails-while-importing-content-packs