LDAP sync is failing no new contacts are showed in the contact list when selecting combine with LDAP
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LDAP sync is failing no new contacts are showed in the contact list when selecting combine with LDAP

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Article ID: 7641

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

LDAP sync is failing no new contacts are showed in the contact list when selecting combine with LDAP and no error is displayed.

The stdlog shows an error similar to this one:

ldap_agent.c 3532 LDAP_Server ldap_bind() error(00E812D8); username(xxxxxxx)

Environment

Service Desk Manager 14.1 or above

Cause

The ldap bind failed because the LDAP DN was not configured properly. The error states that the username (xxxxxx) is not found and if the ldap_dn is not found the synchronization against the LDAP server will not take place.

Resolution

Ensure that the LDAP_DN is properly typed, use an LDAP browser to determine which is the correct context path of the LDAP_DN or ask this information to your LDAP administrator.

An LDAP browser can be downloaded from the links bellow:

Jxplorer or LDAP Browser

Install it on the Service Desk server, Primary or BG Server is optimal choice to simulate connection to the LDAP Server, and use the same parameters used in SD LDAP configuration in order to verify that it is working.

Also refer to existing documentation on how to configure Service Desk with LDAP (link)

Additional Information

The above may happen after an RU update or an execution of the pdm_configure command.  One should also examine the previous NX.env files, including the NX.env_nt.tpl file to see if there is a difference with the NX_LDAP_DN values in prior versions.

NX.env_nt.tpl files may be located in the SDM install folder's pdmconf folder as well as the SDM install folder's REPLACED\XXXX.OLD\pdmconf; XXXX is a given patch install code such as GOL-78_EN_US for SDM 17.4 GA.