Error# '85' during search: 'error: Timed out' when searching role from sharepoint people picker only when it reaches 95000 and above
book
Article ID: 76232
calendar_today
Updated On:
Products
CA Single Sign On Secure Proxy Server (SiteMinder)AXIOMATICS POLICY SERVERCA Single Sign On SOA Security Manager (SiteMinder)CA Single Sign-On
Issue/Introduction
We are getting timeout error while searching through Sharepoint people picker only when users in a given role are more than 95,000 users Role "givenName"
It was observed that when user count is 90000, the error was not reported but when it reached to 95000, we are observing above error
Cause
Search Timeout needs to be increased in Policy Server configuration
Environment
CA Siteminder Policy Server Product Name=CA Single Sign-On Policy Server Full Version=12.52 SP1 CR06 CA SharePoint Agent Product Name=CA SiteMinder Agent for SharePoint Full Version=12.52 SP1 CR04.
Resolution
Please add new registry variable SearchTimeout to increase search timeout in Policy server.
Under this registry path HKEY_LOCAL_MACHINE\SOFTWARE\Netegrity\SiteMinder\CurrentVersion\LdapSessionServer\
Right click on LdapSessionServer -> New -> DWORD (32 bit) value this will create a variable and rename as below SearchTimeout
Set the value of 40 (in seconds)
This registry change should take effect automatically. However, if issue persists after making above registry chnages, please plan a policy server restart.