Connector password is not sticking
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Connector password is not sticking

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Article ID: 75932

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

After setting the password for the IDM connector once, every time when restarting the JBoss service, it prompts for password for the IDM connector again.

Environment

Release: 14.x
Component: IDMGR

Cause

Servers in a cluster are not using the same sigma.keystore file.

Resolution

The password in the connector configuration is encrypted when saved in Identity Portal's database. The encryption / decryption keys are saved on the Portal's server in the 'sigma.keystore' file.
Therefore, when using a cluster of Identity Portal, it is essential that all the servers in the cluster will use the same sigma.keystore file, otherwise each server will use different keys to decrypt and encrypt the passwords which will result in the exact issue reported.
When Identity Portal runs on VAPP, the system should automatically ensure that each node that runs Identity Portal uses the same sigma.keystore. If this is a standalone installation of Identity Portal (i.e. not a VAPP), this has to be configured manually then the sigma.keystore should be copied from one server to the other.