Getting Post Create errors while uploading Userstore and Prov store after integrating with SM
search cancel

Getting Post Create errors while uploading Userstore and Prov store after integrating with SM

book

Article ID: 75113

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

Error on the Identity Manager side when importing provstore and/or userstore after integrating with Siteminder
ImsManagedObjectDefinitionImpl.postCreate 01:46:33,598 ERROR [ims.llsdk.managedobjectdefinition.attributedefinition] (Thread-166) [facility=4 severity=3 reason=0 status=35 message=Failed to fetch SiteMinder user directorySmImsCommand (returnManagedObjectAttributes) Provider call failed Error Code was: -2140798868

May also see a "duplicate id" error in the smps.log.

Environment

Release:
Component: IDMGR

Cause

This error is basically saying that it found the objects already on the Policy Server and can't create them again.  So we have to completely remove them from the Siteminder side first and then import again.

Resolution

Start with the Identity Manager Console. If Userstore and Provstore are there, export and then delete them because they will never sync with siteminder if they are there. Export and delete the enviornment as well. 

Next, use XPSExplorer on the Siteminder side. Need to clear out Identity Manager stuff. Even the ones that say something about in use by IDM and not to remove. We are looking for the IMS directory and IMS environment objects. Start with environment as deleting the directory that is linked to an environment will give an error. Verify IMS directory and environment are gone. 

Restart Application Server

Go back to IDM management console. Import directories.