iis probe does not find any application pools in a remotely monitored system
search cancel

iis probe does not find any application pools in a remotely monitored system

book

Article ID: 74998

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I have successfully added a remote IIS server to be monitored by the iis probe. When I right click Application Pools and select Rediscover, no application pools are returned.

The iis probe log file does not generate any error or failure.

Environment

UIM 8.51
iis (probe) 1.91
IIS 8.5
Windows Server 2012 R2

Cause

This issue may occur when the account defined to start the Nimsoft Robot Watcher service on the robot where the iis probe is running does not have permission to connect to the Remote Registry of the remote IIS server.

Resolution

  • open the Windows Services window (Start > Run > services.msc > OK)
  • double click the Nimsoft Robot Watcher service and select Log On tab
  • change the 'Log on as' account from Local System account to a different account with enough privileges to query the Remote Registry.
As an example you can try an domain service account or perhaps the Network Service account. This depends on the security settings of your environment. For more information please engage your security or infrastructure support team for assistance.