cc=0016 in SMPE APPLY

book

Article ID: 74924

calendar_today

Updated On:

Products

CA RC/Migrator CA Endevor SCM Interface DB2 Administration CA RC Compare for DB2 for z/OS CA RC Extract for DB2 for z/OS CA RC/Query CA RC Secure for DB2 for z/OS CA RC Update for DB2 for z/OS CA Database Analyzer for DB2 for z/OS CA Fast Unload for DB2 for z/OS CA Fast Check for DB2 for z/OS CA Fast Index for DB2 for z/OS CA Fast Load for DB2 for z/OS CA Rapid Reorg for DB2 for z/OS

Issue/Introduction

GIM69185E ** AN INVALID ENTRY HAS BEEN ENCOUNTERED IN THE SMPSCDS DATA SET FOR SYSMOD CPRFJ00.

I am getting an error while running SMPE APPLY for CA Database Management Solutions for DB2 for z/OS v19 . I have restarted the APPLY three times per the error message (GIM69185E) but it keeps failing.

GIM69185E ** AN INVALID ENTRY HAS BEEN ENCOUNTERED IN THE SMPSCDS DATA SET FOR SYSMOD CPRFJ00.

Environment

z/os DB2

Resolution

Checking the jobs i see these messages 

GIM69185E ** AN INVALID ENTRY HAS BEEN ENCOUNTERED IN THE SMPSCDS DATA SET FOR SYSMOD CPRFJ00.
GIM41801I    JCLIN PROCESSING FAILED FOR SYSMOD CPRFJ00.                       
GIM30208I    APPLY PROCESSING FAILED FOR SYSMOD CPRFJ00. JCLIN PROCESSING FAILED
GIM37001S ** APPLY PROCESSING STOPPED BECAUSE FUNCTION SYSMOD CPRFJ00 FAILED.  

GIM57703T ** AN I/O ERROR OCCURRED DURING READ PROCESSING FOR SYSMOD MEMBER 
CTGRJ00 IN THE SMPSCDS DATA SET. APPROXIMATE TTR=000C0C. 
GIM27401T ** I/O ERROR - ,SPCJCAPP,APPLY ,122B,D,SMPSCDS ,READ ,NO RECORD FOUND 000002C7000C0B,BPAM 

It certainly looks like there is some problem with the SMPSCDS dataset. 


I would suggest deleting this install and the datasets. 

Start afresh with a new SMP/E CSI 
Download R19 again run the Receive and make sure that is clean. 

Then run an Apply check and make sure that is clean.