How can we upload / download documents in Service Desk Manager avoiding HTTP Error 405.

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Article ID: 7490

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Cannot upload / download Documents in Service Desk Manager. HTTP Error 405 was seen on IE 11 browser

Cause

The the root cause identified is that the repository and SDM must use the same URL. Hence we need to configure the repository to use the same SDM Hostname and port too

Environment

CA Service Desk Manager 12.9 + CP01CA Service Desk Manager 14.1CA Service Desk Manager 17.0

Resolution

Please follow the below instructions to correct this problem

1) Go to Administration Tab > Attachments Library > Repositories 

2) Select Repository you need to use and configure with SSL > Right-Click and View 

3) Take note of the Server being used 

4) Go to System > Servers > Click on the Server > Edit 

5) Configure the "Attachment Servlet Path" to use correct hostname and port of SDM. For example: http://hostname_of_server:8080/CAisd/UploadServlet 

6) Click the Save button

7) Uploading / Downloading the file again using SDM should work now.