Login page when viewing a Service Catalog attachment via Service Desk
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Login page when viewing a Service Catalog attachment via Service Desk

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Article ID: 74356

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

Popup window asking for credentials in SDM when trying to download from Service Desk Manager a file that is located in Catalog repository. Error in stlogs:

bopauth_nxd 7412 TRACE bopauthobj.c 915 New auth thread created for get_artifact.
bopauth_nxd 7412 ERROR eiamAuth.c 819 Error in authenticating with credentials for user: cnt:ID' - EE_BADOBJECT Bad Object success
bopauth_nxd 7412 ERROR eiamAuth.c 610 Error exporting artifact from session: EE_BADOBJECT Bad Object success
bopauth_nxd 7412 TRACE bopauthobj.c 1587 Received final REPLY: get_artifact; 1;
boplgin 7456 TRACE i18nMsg.c 588 Arg[0] = cnt:ID
boplgin 7456 ERROR bplaccess.c 3807 AHD04023:Security error: get_bopsid/get_artifact (cnt:ID) nil
web:local 7332 ERROR freeaccess.spl 15700 Unable to get ARTIFACT - AHD04023:Security error: get_bopsid/get_artifact (cnt:ID)
boplgin 7456 TRACE i18nMsg.c 588 Arg[0] = <userid>
boplgin 7456 SEVERE_ERROR bpmessage.c 779 BPMessage::operator[3]: index out-of-bounds max = 1
boplgin 7456 SIGNIFICANT bpmessage.c 783 BPMessage [User <userid>]
boplgin 7456 SIGNIFICANT bpmessage.c 783 {
boplgin 7456 SIGNIFICANT bpmessage.c 783 method = get_artifact
boplgin 7456 SIGNIFICANT bpmessage.c 783 arg 0 = (string)cnt:ID
boplgin 7456 SIGNIFICANT bpmessage.c 783 arg 1 = (integer)0
boplgin 7456 SIGNIFICANT bpmessage.c 783 reply object = @.web:local.avBAAA (not refcounted)
boplgin 7456 SIGNIFICANT bpmessage.c 783 reply method = 0
boplgin 7456 SIGNIFICANT bpmessage.c 783 msg origin = COMPILED_SPELL
boplgin 7456 SIGNIFICANT bpmessage.c 783 }
boplgin 7456 SEVERE_ERROR bpobject.c 4998 Attempt to cast type NIL BPData to long
boplgin 7456 ERROR bplaccess.c 4438 AHD04042:Login failed for userid (xxxxxx); login timed out

Environment

Service Management 17.X.

Cause

Cause 1. The user who is trying to download the file from SDM is not using EEM Authentication

Cause 2. The file is missing in the Catalog repository.

Resolution

Solution to cause 1:

Change the access type of the user with the problem to one that uses EEM authentication and/or modify the access type to use EEM authentication.

See:

Modify the New Functional Access Areas Post-Migration

Solution to cause 2:

The file is missing in the Catalog repository so SDM cannot handle the exception and shows up a popup window asking for credentials. The administrator must check the possible cause/scenario for missing the file. Possible options:

1. Multiple Catalog servers not using a common filestore.
2. The file was deleted manually from the repository
3. There was a problem uploading the files to Catalog server.