SOI removing devices from Maintenance mode after 1 hour
search cancel

SOI removing devices from Maintenance mode after 1 hour

book

Article ID: 74347

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

SOI removing devices from Maintenance mode after 1 hour

Environment

Release: SAMBDL99000-4.2-Spectrum-Service Assurance Manager-Promotional Bundle
Component: SOI 4.2

Cause

SCOM connector has a default value for  "MaintenanceModeTime" set to 1 hour. When a CI is set to maintenance in Spectrum it propagates to SOI and SCOM, since SCOM connector has a default timer set for the maintenance, once the maintenance time ends SCOM resets the maintenance mode on the CI back to production

Resolution

To change the default time you can follow these steps on the SCOM connector machine:
1. Open SCOMConnectorConfig.xml from CA\Catalyst\CatalystConnector\container\lib\scom.
2. Find the "MaintenanceModeTime" value: This specifies the number of hours the SCOM CIs are in the maintenance mode. The update method of the SCOM connector can be called to put any SCOM management object to maintenance mode. Example: To put any SCOM management object to maintenance mode for two hours, the parameter is as follows: < MaintenanceModeTime >2</ MaintenanceModeTime >

Note: there is no maximum number of how many hours you can set the MaintenanceModeTime to.

3. Save SCOMConnectorConfig.xml.
4. Restart CA Catalyst Container service.
Note: You have to set a time for maintenance in SCOM as mentioned above, it cannot be indefinite.