Easytrieve IMS Option (LMP key 6T) and CAS9 messages
search cancel

Easytrieve IMS Option (LMP key 6T) and CAS9 messages

book

Article ID: 74283

calendar_today

Updated On:

Products

PanAudit Plus Easytrieve Report Generator PAN/SQL

Issue/Introduction

In the CAIRIM KEYS DD file, commenting out the Easytrieve UMS option LMP key for 6T or not using a valid LMP key for the IMS option will result in error messages CAS9180E as well as CAS9012A and CAS9013A i.e.
CAS9180E - CPU ****** Requires a LMP key to run Prod (6T)     
How can the IMS option be removed?

Environment

Easytrieve for IMS r11.6

Cause

If the license for the IMS option is no longer active, Easytrieve IMS jobs will still always invoke the CAS9 messages.
NOTE: The LMP key 6T is only checked at compilation time, not runtime.

Resolution

To disable the IMS option remove or rename load module EZTPB37. The CAS9 messages will then stop.

Additional Information

If it is required to use the IMS option and you are already licensed for it then the LMP key can be accessed using self-service from the Broadcom Support portal.
After login the My Dashboard page will show option My Entitlements.
Under My Entitlements search for your SiteID and you should be able to access your LMP keys.
Expand product name "Easytrieve Report Generator" and then for the first "Easytrieve Report Generator" line click on "Entitlement Details" e.g


For any Serial Number line use its Licenses hyperlink and it will load a page showing a "License Keys" tab e.g.



Some Serial Number lines Licenses hyperlinks may show a "License Keys" tab whereas others will not. For those that do they will all have all the same licenses listed regardless of the original product name chosen.
Useful article and doc. links:
License Installation Instructions for Mainframe LMP Keys
Add Product License Keys - SITEID Type LMP Keys
If any problems are found accessing or using the 6T LMP Key code please contact Broadcom support via a new support case.