The Software Asset Manager to Asset Portfolio Management integration is not working. Device updates or inserts are not syncronizing from SAM to APM.
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The Software Asset Manager to Asset Portfolio Management integration is not working. Device updates or inserts are not syncronizing from SAM to APM.

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Article ID: 7422

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

CA Software Asset Manager device inserts or updates are not updating to CA Asset Portfolio Management.  The ImportDriver.log shows the error: 

2017-06-29 21:57:07,633 UTC [6424] DEBUG CA.Applications.ImportDriver.Program - Import Command:C:\Program Files (x86)\CA\ITAM\Import Processor C:\Program Files (x86)\CA\ITAM\Import Processor -usr "uapmadmin" -pwd "uapmadmin" -i "CA APM - Device Insert or Update Import" -df "C:\Program Files (x86)\CA\ITAM\Import Driver\Input\1498773384_CAITAM_Assets_to_be_updated.csv" -c "1" -t "" -ts 
2017-06-29 21:57:07,771 UTC [6424] ERROR CA.Applications.ImportDriver.Program - Importer Error processing file: C:\Program Files (x86)\CA\ITAM\Import Driver\Input\1498773384_CAITAM_Assets_to_be_updated.csv as 1498773384_CAITAM_Assets_to_be_updated.csv 
System.NullReferenceException: Object reference not set to an instance of an object. 
at CA.Applications.ImportDriver.Program.LaunchDataImporterConsole(Int32 utcDateTimeNow) 
2017-06-29 21:57:07,783 UTC [6424] INFO CA.Applications.ImportDriver.Program - Exiting LaunchDataImporter

 

Environment

CA Asset Porfolio Management 14.x, any patch levelCA Software Asset Manager 4.x, any patch level

Cause

The path to the importprocessor.exe file is absent or not correct. 

Resolution

In APM, navigate to Administration -> System configuration -> SAM Import Driver  and correct the path to the importprocessor.exe file:  

<Please see attached file for image>

src="/servlet/servlet.FileDownload?file=0150c000004AK2oAAG" alt="APMImportDriverConfig.png" width="1089" height="457">

After saving the configuration, perform an IISRESET and restart the CA APM services. 

Attachments

1558703166322000007422_sktwi1f5rjvs16q5a.png get_app