e2e_appmon continuously giving unable to start error as alarm
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e2e_appmon continuously giving unable to start error as alarm

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Article ID: 74044

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

This is a scenario where the e2e environment/permission issues interfered with the script run, the customer could run the source script on the e2e workstation/server using the nimrecorder and it would execute without any error/issues. But, after logging out of the e2e workstation and trying to run the script just using the probe, e.g., rt-click->Start at Once or running the script based on the configured script interval, it would continuously throw the alarm/error:

"Unable to start(error)"

The e2e GUI displayed a return code of 255 in the e2e probe Status run stats, e.g., Return code (last run)

Environment

  • UIM 8.5.1 or higher
  • e2e_appmon_dev v2.25 or higher

Cause

  • The e2e "screen dump" directory did not having the required security privileges.

     

Resolution

Once the customer updated the Windows machine security settings, giving privileges to the e2e directory where the screen dumps were normally stored, the script ran without error.