Enterprise dashboard is not coming up - server is not running

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Article ID: 7395

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Updated On:

Products

CA Application Test Service Virtualization CA Continuous Application Insight (PathFinder) CA Service Virtualization (DevTest / LISA / VSE / Application Test)

Issue/Introduction

Enterprise Dashboard is not coming up.  The  enterprisedashboard.log  shows the following error. 

Trapped Exception: Address already in use 

Trapped Message: java.net.BindException: Address already in use 

 

 

 

Cause

Trapped Exception: Address already in use  means  you have another process bound to the same port.  

Enterprise Dashboard URL port is by default set to 1506

When we did a netstat on port 1506 , we saw that customer had a system level process PID (4) taking port 1506. 

Environment

All support DevTest builds.

Resolution

You have couple of options:

1.  Kill the process that is running on  port 1506.  Restart the Enterprise Dashboard.  

or 

2. Change Enterprise Dashboard port  to another open port (say for example 1706).  Make the following changes to  the below files

open site.properties and update the following line

devtest.enterprisedashboard.port=1706

Also in dradis.properties file add this property. 

dradis.webserver.port=1706 

Restart the Enterprise Dashboard. 

Additional Information

https://docops.ca.com/devtest-solutions/10-1/en/administering/monitoring/use-the-enterprise-dashboard/reactivate-a-registry-or-enterprise-dashboard