When accessing Service Desk using a browser in an iPad, multiple prompts for login credentials pop up.
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When accessing Service Desk using a browser in an iPad, multiple prompts for login credentials pop up.

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Article ID: 7360

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Scenario:

- Service Desk Manager configured with IIS

- Service Desk access types set to allow External Authentication

- IIS set up for Windows Pass-Thru Authentication

- From windows PCs on the same domain for which the Service Desk servers belong to, the users are not prompted for credentials

- When accessing Service Desk Manager using a browser on an iPad or other mobile device, hitting the IIS URL, the user gets multiple prompts for credentials prior to getting the login screen

Environment

CA Service Desk Manager - All Versions

Cause

This is due to the fact that the iPad or other mobile device is NOT on the domain, thus it cannot pass domain credentials to the browser, and on to IIS to log the user into Service Desk.   Because Windows Authentication is enabled in IIS, the browser on the mobile device gets prompted for windows credentials to access the Service Desk web client login page.

Resolution

To get around this, the solution is to have your mobile device users access Service Desk using the Tomcat URL and port, rather than IIS. Since most likely Windows Authentication wont be enabled on the tomcat port, the user will get right to the Login Page and can log into Service Desk.