Root cause alarms showing in SOI Console
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Root cause alarms showing in SOI Console

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Article ID: 73535

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Updated On:

Products

CA Spectrum

Issue/Introduction

Alerts are showing up in the SOI console from Spectrum connector that do not show up in Spectrum.
These have a summary of "Device is unreachable"

Also seen in the Connector log are entries looking like this: 

AlertDiagnosis=Symptom

Environment

Release:
Component: SPCINT

Cause

By default Spectrum will send over Root Cause Analysis (RCA) alarms over to the connector and then into SOI.
SOI does not support these conditions, so it has a place holder alarm for the RCA alarms from Spectrum and it has a critical condition in SOI.

Resolution

Set enableRCA to 0 in the SOI Administration webpage for the connector.
Or, it can be done on the connector machine by editing SOI\resources\Configurations\spectrumim_<hostname>_<spectrumserver>.xml file.

Default value is “enableRCA="1” 

Change this into “enableRCA="0” 

Restart the CA Integration Service, and the connector.

Additional Information

Enabling RCA feature works for new alarms only since enabled, not for existing alarms.