The Automatic Message Recognition (AMR) facility has stopped intercepting messages and Jobtrac no longer issues the required commands automatically
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The Automatic Message Recognition (AMR) facility has stopped intercepting messages and Jobtrac no longer issues the required commands automatically

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Article ID: 7350

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Updated On:

Products

Jobtrac

Issue/Introduction

The Jobtrac   AMR  facility appears to no  longer monitor system messages and does not  prompt or  respond to them automatically.  To use the AMR feature of Jobtrac,  the IBM IEAVMXIT WTO Intercept user exit must exist in SYS1.LINKLIB data set, for AMR triggers.  The IEAVMXIT installation exit allows you to modify message process in a system or Sysplex.   While running Jobtrac, it can happen that the AMR facility stops intercepting messages.  This can cause Jobtrac to stop issuing the required commands automatically, causing a delay in batch workload.

 

 

Environment

CA Jobtrac 11.0

Cause

If the Jobtrac  Automatic Message Recognition (AMR) facility stops intercepting messages, it is usually because the IBM IEAVMXIT WTO Intercept user exit has abended. Since this exit is used by many software products, the problem determination and resolution process must include careful examination of each product that uses this exit.   After the cause of the abend has been determined and resolved, the AMR facility must be reestablished.

 

 

Resolution

To reestablish the AMR facility, it is necessary to execute the following steps:

 

1. Issue a 'D MPF' command from the OS console. If the output indicates that IEAVMXIT is in ABENDED status, issue a 'K M,UEXIT=Y'.

2. Issue a 'D MPF' again. It should show ACTIVE status, as seen in the following sample display. If the status is INACTIVE, an IPL may be required to resolve the problem.

 

   00210 D MPF

   00010 IEE677I 12.55.54 MPF DISPLAY 971

   00010 MESSAGE ID -MPF SUPPRESS RETAIN AUTO TOKEN EXIT

   00010 CAIWDBUG -__ YES YES NO

   00010 CAJR3__I -__ YES YES NO

   00010 CAJR31_I -__ YES YES NO

   00010 CAJR32_I -__ YES YES NO

   00010 CAS9115I -__ YES YES NO

   00010 DFH1523 -__ YES YES NO

   00010 DSI_9_I -__ YES YES NO

   00010 IEC_7_I -__ YES YES NO

   00010 IEC13_I -__ YES YES NO

   00010 IEC161I -__ YES YES NO

   00010 IEF236I -__ YES YES NO

   00010 IEF237I -__ YES YES NO

   00010 IEF677I -__ YES YES NO

   00010 IOS427A -__ YES YES YES

   00010 IST53_I -__ YES YES NO

   00010 IST532I -__ YES YES NO

   00010 VCS_2_1E -__ YES YES NO

   00010 CAINEXIT_ -__ YES NO NO

   00010 CASNTRAC_ -__ YES YES NO

   00010 CAS9TRAC_ -__ YES YES NO |== ___ ACTIVE STA

   00010 GENERAL WTO USER EXIT (IEAVMXIT) ACTIVE<=====

   00010 FIELD -MPF COLOR HLIGHT INTEN FIELD -MPF COLOR HLIGHT

   00010 URGATTN -DFL RED NONE HIGH IMEDACTN -DFL WHITE NONE

   00010 EVETACTN -DFL GREEN NONE NORM GENMSG -DFL GREEN NONE

   00010 PPMSG -DFL GREEN NONE NORM SELPEN -DFL BLUE NONE

   00010 INSTRERR -DFL WHITE NONE HIGH ENTRYARA -DFL GREEN NONE

   00010 WARNLGEN -DFL BLUE NONE NORM WARNRGEN -DFL BLUE NONE

   00010 WARNRURG -DFL RED BLINK HIGH OOLCNTL -DFL TURQU NONE

   00010 OOLLABEL -DFL TURQU NONE NORM OOLDATA -DFL GREEN NONE

   00010 COMMAND USER EXITS NOT FOUND

  3. Issue: 

     S VINITx,PARM='ONLY=GJTRVMXT'

4. If loading a new AMRTABLE, issue:

    F JOBTRACx,M=amrname

5. Finally, issue the following sequence of 'XON' and 'XOFF' commands:

a. Enter: XON

   Output from the XON command:

     00000210 XON

     80000010 IEE3_5I XON COMMAND INVALID

b. Enter: XOFF

   Output from the XOFF command:

     00000210 XOFF

    80000010 TRAC_29I - MESSAGE EVENT PROCESSING STOPPED.

c. Enter: XON

   Output from the XON command:

     00000210 XON

     80000010 TRAC_29I - MESSAGE EVENT PROCESSING STARTED.

 

If, after these suggestions, the problem is not solved, please open a Case with Broadcom Support.