Form Does Not Display Existing Users in Group
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Form Does Not Display Existing Users in Group

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Article ID: 7319

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

You create a form in Identity Portal (IDP) to allow administrators to search and add users to a group.

You create a Modify Group task in IM --> map it to a Task in IDP --> create a form with Profile and Membership --> in Membership tab, you configure as follow:

- Property name = Members

- Property Type = Relations

- Server Type = String

- Target Name = Membership-Tab-Users

- Target Object = User

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When an administrator opens the form to add members into a group, no existing users are listed. In Identity Manager User Console, the related Modify Group task displays existing members fine.

Environment

IDP R12.6.8

Cause

Existing members are retrieved from the "User ID" field in Membership tab of the Modify Group task in IM. If this field is not present, you will see the problem.

Resolution

Ensure that "User ID" field is displayed under Membership tab of the Modify Group task in IM:

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If the field does not exist, modify the task, e.g "[Sigma] Modify Group", to include the field:

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Attachments

1558703080156000007319_sktwi1f5rjvs16q4b.png get_app
1558703078224000007319_sktwi1f5rjvs16q4a.png get_app
1558703076346000007319_sktwi1f5rjvs16q49.png get_app
1558703074343000007319_sktwi1f5rjvs16q48.png get_app