Common Administration Framewok (CAF) Failure Error when upgrading to CASM R17.x
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Common Administration Framewok (CAF) Failure Error when upgrading to CASM R17.x

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Article ID: 7306

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When attempting to upgrade CA Service Management to R17.x, you may receive the following error in the installer:

"Common Administration Framework (CAF) Install/Upgrade Failed"

Screenshots (CASM is being installed in German language):

<Please see attached file for image>

error_caf_r17_upgrade.png

 

<Please see attached file for image>

install_checklist_screenshot_with_error.png

Environment

CA Service Management including:- CA Service Desk Manager- CA Service Catalog

Cause

The problem is found to occur ONLY in environments where CA Service Catalog is being upgraded as part of the CA Service Management upgrade to R17.x, where CA DSM r12 Application Framework is installed.   The installer attempts to run the "command "taskkill /F /IM CAF.exe" " to kill the CAF process, however, the process fails to stop, or is automatically restarted by some other mechanism, thus the installer is not able to upgrade this piece of the product, and throws the error.

Resolution

The workaround for this if you encounter this error is to stop the "CA DSM r12 Application Framework" service from the services console, and then click the "Retry" button on the installer, which should allow the install to continue from where it left off and successfully complete.

Attachments

1558703208291000007306_sktwi1f5rjvs16q5m.png get_app
1558703206378000007306_sktwi1f5rjvs16q5l.png get_app