The Export button does not work since enabling SSL in Service Desk Manager
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The Export button does not work since enabling SSL in Service Desk Manager

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Article ID: 7304

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

I have configured my Service Desk Manager environment for SSL, but now the export button no longer works.

Environment

Release: SDM 17.x
Component: Export

Cause

NX_SERVLET_SERVER_URL and/or NX_LOCAL_SERVLET_SERVER_URL pointing to non-SSL URL

Resolution

Log into the Service Desk Manager application server and browse into the installation folder. Within the root of the folder take a backup of the NX.ENV file and then edit the following variable:

@NX_SERVLET_SERVER_URL=http://servicedeskhostname:8080

Change it to

@NX_SERVLET_SERVER_URL=https://servicedeskhostname:8443

In the example above "servicedeskhostname" would represent the hostname of the ServiceDesk server, and 8443 is the port.

Save the file and recycle services of CA Service Desk Manager for the change to take place.