search cancel

QOS metrics are not displayed in Operator Console

book

Article ID: 7284

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The user is not seeing data in Operator Console for server even though we see data being collected in Raw tables

Environment

UIM 8.x, 9.x
UIM 20.x

Cause

The issue is reported because the server where the robot is deployed has a different name than what is provided in robot configuration.
This issue can also occur when the source in the qos_message is different than the robot config.

Resolution

The controller probe allows for the server display name to be set as per requirement irrespective of the original hostname.
But this in turn leads to confusion as the probes deployed on server still continue to send data with original hostname. 

In order have the data available in DB and in reporting as per name set in controller please perform below changes as well.

Open Controller GUI-->Setup-->Misc

Under Misc. tab look for 'Quality of Service'
Check mark 'Set QoS Source to robotname instead of computer hostname'

This will in turn set all QoS coming from source as robot name set in robot configuration rather than an incorrect hostname.

Additional Information

Note :This option is disabled unless the Set specific name (override) option is selected on the Setup, Nimsoft tab.

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/controller/controller-im-configuration.html