Workpoint adapter not responding
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Workpoint adapter not responding

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Article ID: 72832

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

 

 

The import progress to create a universe stuck at "0% in progress". An error "The Workpoint adapter is not responding, perform a Workpoint Checkup" if the universe is opened.

 

 

 



Performing those below actions throws some more errors:

 

- Running Workpoint Checkup gives a lot of errors "missing essential workpoint process [xxxx]"

- Running the “Update” function for the Workpoint DB Administration fails with error "Import has failed. Exception is: Invalid TableID. TableID cannot be null!"

 




Eurekify logs show:

 

17:29:40,265 INFO  [stdout] (default task-34) 2018-03-05 17:29:40,265 [default task-34] ERROR com.workpoint.server.pojo.UniqueIDUpdatePvtBean  - spWP_GET_NEW_ID returned null Database value, probably because it cannot find row in WP_INI table for SECTION_NAME='Database' and KEY_NAME='ID', so cannot construct TableID.

 

17:38:30,140 INFO  [stdout] (Query_actionq#ActionQ1#WPDS) 2018-03-05 17:38:30,140 [Query_actionq#ActionQ1#WPDS] ERROR com.workpoint.server.pojo.GenericServerBean  - Could not find stored procedure 'SPWP_ASSIGN_SCRIPT_MON_ROWS'.

17:38:30,143 ERROR [org.jboss.as.ejb3.invocation] (Query_actionq#ActionQ1#WPDS) JBAS014134: EJB Invocation failed on component MonitorPvt_EJB for method public abstract com.workpoint.common.data.table.ScriptMonitorTable[] com.workpoint.server.pojo.MonitorPvt.queryScriptQMonitors(java.lang.String,java.lang.String,java.math.BigDecimal,java.lang.String,java.lang.String,java.lang.String,java.lang.String,java.lang.String[],java.lang.String,boolean,java.lang.String,boolean,int,boolean) throws com.workpoint.server.ejb.WorkPointEJBException: com.workpoint.server.ejb.WorkPointEJBException: An SQL Exception has occurred. Please see the server logs for details.



 

 

Environment

Virtual Appliance version 14.x

Cause

Due to incorrect database Collation configuration for Workpoint tables.

 

Resolution

Dropping and re-creating the Workpoint DB with Latin1_General_CI_AI fixes the issue.

Important note: Depending on business requirement about how data should be sorted and compared, the DB Collation might need to be configured differently from the overall database.