Why is my two tier NFA 9.3.8 not showing Enterprise Overview Data or Last Flow Times?
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Why is my two tier NFA 9.3.8 not showing Enterprise Overview Data or Last Flow Times?

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Article ID: 72818

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA)

Issue/Introduction

NFA 9.3.6+ is not showing Enterprise Overview Data or Last Flow Times.

When looking at the \CA\NFA\Reporter\logs\Pump*.log file on the console server you may see messages like below:
     FilePumpManager: Fetching of data files from Harvesters will resume when the number of RPR files in input/staging directories (127) falls below ReaperFileThreshold (100).

If you look in the \CA\NFA\Reporter\input\staging\ directory on the console server, you will see 100 or more files in that directory.
If you see rpr files other than *.hostg.rpr or *.protog.rpr in that directory, follow the steps below.
 

Environment

NFA 9.3.8

Cause

This could be caused by converting from a 3 tier to a 2 tier NFA environment.

Resolution

1. Check the harvester.parameter descriptions table to see if if the setting below is set to 'Y' or 'N"
mysql harvester


select * from parameter_descriptions where parameter='EnableRPR';



2. If it is set to 'Y' run the following commands on the Harvester:


mysql harvester
update parameter_descriptions set defaultvalue='N' where parameter='EnableRPR'; 



3. Recycle the CA NFA Harvester service.

4. Delete all files from the \CA\NFA\Reporter\datafiles\Input\Staging directory on the Console.

5. Delete all files from the Harvester's \CA\NFA\Netflow\datafiles\NFMinput directory.

6. Restart the Netqos ReporterAnalyzer Pump Services on the Console server.

7. After a period of time verify that you are seeing Last Flow times updated on routers, these process every 15 minutes, and also verify that Enterprise Overview data is visible.