A newly created user is unable to start Jasper server Tomcat

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Article ID: 7277

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Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM SaaS - Application Clarity PPM On Premise

Issue/Introduction

A new user who tries to start and stop jasper server receives the following error.

WARNING: Unexpected exception resolving reference 
java.lang.RuntimeException: KeystoreManager.init was never called or there are errors instantiating an instance. 

Cause

KeystoreManager.init errors may mean in the situation above that the service cannot find Jaspersoft license files.

Whilst installing the product, on Windows, Jaspersoft creates the following files in the user’s home directory:

example c:\users\Administrator

Jasperserver.license, .jrsks, .jrsksp and .jslic

Environment

Release: ESPCLA99000-14.3-Clarity-Extended Support Plus
Component:

Resolution

Copy the following files from the home directory: example c:\users\Administrator to the new user who is experiencing the error. 

Jasperserver.license, .jrsks, .jrsksp and .jslic

Then start the Jaspersoft Tomcat again.