A Microsoft Windows user is unable to start Jasper server Tomcat
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A Microsoft Windows user is unable to start Jasper server Tomcat

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Article ID: 7277

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

A new user who tries to start and stop jasper server receives the following error.

WARNING: Unexpected exception resolving reference 
java.lang.RuntimeException: KeystoreManager.init was never called or there are errors instantiating an instance.

Cause

KeystoreManager.init errors may mean in the situation above that the service cannot find Jaspersoft license files.

Whilst installing the product, on Windows, Jaspersoft creates the following files in the user’s home directory:

example c:\users\Administrator

Jasperserver.license, .jrsks, .jrsksp and .jslic

Resolution

Copy the following files from the home directory: example c:\users\Administrator to the new user who is trying to start the Tomcat service and experiencing the error. 

  • Jasperserver.license
  • .jrsks
  • .jrsksp
  • .jslic

Then start the Jaspersoft Tomcat again.

Additional Information

During a Jaspersoft upgrade, the install error below may occur if the .jrsks and .jrsksp files are in the Microsoft Windows user's profile (Example c:\users\Administrator) of user trying to install Jaspersoft.

D:\clarity_jaspersoft_7.1.3_6.3.0.14\buildomatic>echo off 
Buildfile: D:\clarity_jaspersoft_7.1.3_6.3.0.14\buildomatic\build.xml
     [echo] Filtering properties (cleaning out blank spaces)
[create-ks] java.io.IOException: Keystore was tampered with, or password was incorrect

BUILD FAILED
D:\clarity_jaspersoft_7.1.3_6.3.0.14\buildomatic\build.xml:55: The following error occurred while executing this line:
D:\clarity_jaspersoft_7.1.3_6.3.0.14\buildomatic\bin\setup.xml:315: Keystore may have been tempered with.

Total time: 0 seconds

BUILD FAILED
D:\clarity_jaspersoft_7.1.3_6.3.0.14\install.xml:332: The following error occurred while executing this line:
D:\clarity_jaspersoft_7.1.3_6.3.0.14\install.xml:1345: The following error occurred while executing this line:
D:\clarity_jaspersoft_7.1.3_6.3.0.14\install.xml:984: The following error occurred while executing this line:
D:\clarity_jaspersoft_7.1.3_6.3.0.14\install.xml:2080: ERROR: Error during running this ant target @{arg}
                        For more details, please check D:\clarity_jaspersoft_7.1.3_6.3.0.14/install.log file

Confirm by removing incorrect .jrsks and .jrsksp files from the user profile. You could also copy the files from the user profile of user (who initially installed Japsersoft successfully) to fix install error.