Traps are not being processed by Spectrum. Packet capture tools shows that the trap is received on the Spectrum server, however the trap is not processed by Spectrum.
Environment
Any Spectrum version
Cause
This can happen if the "Agent-addr" is not configured properly on the device which is sending the Trap.
Resolution
Spectrum will process the trap as long as the IP address of the agent address is an IP address known to be configured on the model. When Spectrum creates an snmp model, Spectrum reads the IP addresses in the ipAddrTable and ipAddressTable mibs and stores them to the deviceIPAddressList attribute on the model. So, as long as the IP address of the agent address of the trap is a known configured IP address of the model, Spectrum will process the trap on that model.
When Spectrum creates a Pingable model, it stores the ip address of the Pingable model to the deviceIPAddressList attribute. That is the ONLY ip address known for that model. So if the ip address of the agent address in the trap is not in the deviceIPAddressList, it will not be mapped to that model.