Agent is running but shows Inactive
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Agent is running but shows Inactive

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Article ID: 72590

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Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

The services are running for Agent, but it appears as Inactive in the Workload Automation DE Desktop Client Topology. An attempt to restart the agent did not resolve the issue. 

The following error was evident in the agent log file:
The conversation ##.###.##.###:51770->##.###.##.###:7520 is unable to receive the prefix. The exception is Read timed out

Environment

Release:
Component: INFAGT

Cause

A large number of spool files; in excess of 100,000, existed under the agent.

Resolution

If the agent is not configured to clean up spool on success, you should do so by defining the following in the agentparm.txt file:
  • agent.spool.success.autocleanup=true
  • runnerplugin.spool.expire=10D
  • runnerplugin.spool.sleep=1D

In addition to the above, one should create a backup of the spool and database directories, then delete them. Once these directories are deleted, start the agent. This activity performs a cold start and the agent rebuilds its own database and re-creates the spool directory. The agent should now reflect as Active in the Workload Automation DE Topology and should once again be able to process work as expected.