ppm error MONS-025 in Admin Console when trying to access the sqlserver probe configuration
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ppm error MONS-025 in Admin Console when trying to access the sqlserver probe configuration

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Article ID: 72525

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

On opening the configuration screen for the 'sqlserver' probe in the Admin Console, we are presented with an error:

Message:
The probe provisioning service at probe address "/UIMDomain/UIMHub/hostname/ppm" reported a failure.
Resolution: Please review the PPM probe logs and resolve any issues before continuing.
Error Code: MONS-025"
 
The configuration for another sqlserver probe on a robot on the same network works fine.

Restarting as well as Deactivating and Activating 'sqlserver' and 'ppm' did not help.

Environment

- UIM 8.51 or higher
- sqlserver 5.30 or higher

Cause

- The config file for the sqlserver.cfg file was corrupted. This may happen if direct edits were done with a text editor or the probe utility.

- You can try to investigate the corruption via Notepad++. Choose View->Show Symbol->"Show ALL Characters" option in Notepad++ and carefully inspect the file contents for corruption.

Resolution

  1. Save the sqlserver_monitor.cfg
  2. Inspect it for corruption and if found repair it or delete the bad entry/characters/profile
  3. Delete the 'sqlserver' probe and redeploy it