NetOps Data Aggregator fails to start or synchronize with Portal
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NetOps Data Aggregator fails to start or synchronize with Portal

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Article ID: 72241

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

DA Hangs and never starts loading attributes

DX NetOps Performance Management Data Aggregator fails to start properly after OS patching.

The Data Aggregator (DA) dadaemon service was unable to start after an OS patching and shows synchronization failure in Portal.

The DA is owned and run by a sudo root non-root user.

The following error message is found in the (default path shown) /opt/IMDataAggregator/apache-karaf-<version>/data/logs/karaf.log file.

ERROR | xtenderThread-41 | 2018-02-26 10:21:01,022 | BrokerSetup | m.core.provision.jms.BrokerSetup  169 | om.ca.im.common.core.jms |       | java.io.FileNotFoundException: /opt/IMDataAggregator/apache-karaf-2.4.3/deploy/local-jms-broker.xml (Permission denied)

Environment

All supported DX NetOps Performance Management releases

Cause

System reset ownership

Resolution

Check the permissions on the /opt/IMDataAggregator/apache-karaf-<version>/deploy/ directory.

It should be owned by the non-root service account that runs the DA processes. If it is not take these steps.

  1. Stop the dadaemon and activemq services.
  2. Change ownership to ensure the deploy directory is owned by the proper user.
  3. Start the dadaemon and activemq services.