CA UIM CABI login access denied for superuser after creating a test Organization
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CA UIM CABI login access denied for superuser after creating a test Organization

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Article ID: 72228

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Customer can login successfully into CABI portlet with 'Superuser' account but is then greeted with the following message: "Access Denied You do not have permission to view this page. Please contact your system administrator or log in as a user with permission"

Environment

Release : any UIM Version 
Component: Any cabi probe version 


CABI is installed on a standalone machine.

Cause

From superuser role, ROLE_USER, ROLE_ADMINISTRATOR was missing. ROLE_ADMINISTRATOR was missing from CABI_REST_USER.

Resolution

There are three tables that contain information about CABI users and their user roles:

JIUser is user table.
- JIRole is role table.
- JIUserRole is joint table
 


- Checked in JIUserRole table, just role ROLE_SUPERUSER was assigned to 'superuser' user.
- Insert a row in JIUserRole table, assigned below roles to 'superuser' user:
       --> ROLE_USER
       --> ROLE_ADMINISTRATOR
- Also, add ROLE_ADMINISTRATOR role to CABI_REST_USER.
- Deactivate/activate cabi probe.
 

Additional Information

https://community.jaspersoft.com/wiki/setting-row-level-security