Cannot upload JMeter script to CA App Synthetic Monitor.

book

Article ID: 7187

calendar_today

Updated On:

Products

CA Application Synthetic Monitor (ASM) CA App Synthetic Monitor NIMSOFT CLOUD USER EXPERIENCE MONITOR

Issue/Introduction

 We created a script for a new monitor. When trying to upload the script to the monitor in the CA App Synthetic Monitor portal, it did not complete successfully. Once clicking on the "Continue" button, the "Validating script" popup window would appear as usual, but disappear shortly after, without any further error message or progress.

Cause

 The root cause is due to an incompatible JMeter version used to create the script. CA ASM 8.7 currently does not support this version. The highest JMeter version supported by CA ASM 8.7 is 2.13.


Environment

CA App Synthetic Monitor (CA ASM) 8.7

Resolution

 Re-save the script to JMeter 2.13 compatible, before uploading to CA ASM 8.7

 

Additional Information

 Support for JMeter 3.x will be considered in future CA ASM release.