CMDB for z/OSNetSpy Network PerformanceNetMaster Network AutomationSOLVENetMaster Network Management for SNANetMaster Network Management for TCP/IPNetMaster File Transfer ManagementSOLVE:Operations AutomationSOLVE:Access Session ManagementSOLVE:FTS
Issue/Introduction
When using &CALL UTIL0039 @FCODE=1 @USRID=&USER @OLDPW=&PASSWORD in Solve Easinet procedure we sometimes get messages IRR401I 33E ABEND DURING RACF PROCESSING OF ALTERI REQUEST FOR ENTRY *userid* IRR401I 33E ABEND DURING RACF PROCESSING IRR413I RACF MANAGER REQUEST ID WAS RIN00015
Note: *userid* is the actual Userid
This can abend with valid or invalid user/password.
Environment
Release: SLFTS.00200-12.1-SOLVE:FTS Component:
Cause
Each &CALL involves an attach and a detach. It looks like RACF has started a subtask to update the profile (ALTERI being the request) and it is a timing issue of whether it has finished before the SOLVE maintask issues a detach.
Resolution
Run UTIL0039 not through a single call, but through a SUBSYS feature using SUBSYS DEFINE=UTIL0039 command which can be set in NMINIT member. By this way, the detach is avoided. For this purpose, replace &CALL UTIL0039 into &CALL SUBSYS=UTIL0039.