snmpcollector Profiles Show to be in a failure state
search cancel

snmpcollector Profiles Show to be in a failure state

book

Article ID: 7078

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After upgrading snmpcollector, profiles that were previously working now are not

Symptoms may include the following:

  • Yellow warning icon next to the profile
  • "Profile in failure state" error when viewing the properties of the profile
  • Log file contains the following entries

Jun 14 12:44:22:857 [DiscoveryController6, snmpcollector] DeviceDiscovery failed: <device> in state Discovery Failed. Reason: Credentials Invalid or device is unreachable.  Unable to communicate with device using given credentials

Jun 14 12:44:22:860 [DiscoveryController6, snmpcollector] TIMING: discover device (<device>)  took 8003

Environment

snmpcollector 3.x or 4.x

Cause

This error is being caused by snmpcollector not having enough time to scan the device.

Resolution

The resolution for this is to increase the timeout values using raw configure

  1. In Infrastructure Manager, browse to the problematic snmpcollector 
  2. Hold down the Shift key and Right Click on the probe
  3. Click Raw Configure
  4. Click the Setup node
  5. Look for a Key called SNMP_TIMEOUT
  6. If this key does not exist, click "New Key" to create it
  7. Set the value to 60000
  8. Click OK
  9. Click OK to close the Raw Configure window

The probe will restart automatically