In an integrated environment with UIM some alarms in SOI are showing 'Unknown' in the Name column
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In an integrated environment with UIM some alarms in SOI are showing 'Unknown' in the Name column

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Article ID: 7041

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I noticed some alarms in SOI have 'Unknown' in the 'Name' column. After reviewing the article TEC1344659 it seems the root cause is the corresponding devices in UIM have a NULL value in the dns_name column of CM_COMPUTER_SYSTEM table.

Environment

Release: CNMSPP99000-8.4-Unified Infrastructure Mgmt-Server Pack-- On Prem
Component:

Cause

Since UIM 8.31 the dns_name field can get populated less frequently than before. Please see the article TEC000005241 for details of the new update process.

Resolution

The dns_name field in CM_COMPUTER_SYSTEM table will get populated by the discovery_agent probe when the device is discovered.

In order for this process to work the server where discovery_agent is running must be able to do a reverse lookup on the target device's IP address. 

If the reverse lookup works fine then running the Discovery Wizard against the problem devices should resolve the problem:

  • In UMP click 'Actions' and select 'Discovery Wizard'. Select the hub (it must have the discovery_agent probe installed for this process to work), click 'Launch Wizard', click 'Scopes' at the top right of the Discovery Wizard window and click 'New Scope'. 
  • Now give the scope a name and add the IP addresses of all the affected servers. Go to the 'Schedule' tab and select an option to run the discovery. If you are able to run the discovery immediately just select 'Run discovery now' and click 'Finish'. If not you can schedule it to the most convenient time.