Transport Failed Message in Broker Log
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Transport Failed Message in Broker Log

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Article ID: 7038

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Updated On:

Products

CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

The Broker log is full of Transport failed -  Channel was inactive for too long messages.

Message Example:


INFO: Transport failed: java.io.EOFException
com.itko.activemq.broker.TransportConnection serviceTransportException
INFO: Transport failed: com.itko.activemq.transport.InactivityIOException: Channel was inactive for too long: /xxx.xxx.xxx.xxx:aaaaa

Where: xxx.xxx.xxx.xxx:aaaaa is an IP and port combination.

Environment

All supported DevTest platforms.

Cause

When starting the broker, a few of these messages is normal.


However, several thousand messages indicate the broker recovering from a corrupt solr cache.

Resolution

  • Shut down all DevTest components 
  • Delete or move lisatmp_X.1 logs folder . 
  • Delete the DEVTEST_HOME/searchData/solr directory. This directory is a db cache and was, most likely, corrupted by the orphaned Broker. 
  • Restart DevTest components and the solr directory will be recreated. 



If the above does not resolve the issue, there is a possibility that a process running an agent has become unstable. 
To check for this:

  • Open the ATK and connect to the Registry
  • For each agent, turn Pathfinder Off by clicking on the first icon next to each agents name.
  • As each agent has Pathfinder turned off, check the broker log to see if the issue is resolved.
  • If all agents have Pathfinder turned off and the issue is still present, starting checking for orphaned processes on each agent machine.