Getting Error: a value is required for repository type.