Discovery wizard missing for all or some users.

book

Article ID: 6926

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

Some times, when logging in to UMP, we might find that our discovery wizard (gear) is:

 

a) missing and there is an error shown when we hover over the "Inventory" field:

 

b) missing and there is no explanation.

Cause

1) If we are running into problem a), we would see something like this:

 

<Please see attached file for image>

discovery.png

  • The above situation is seen regardless of the user (even "Administrator" user faces it)

2) If we are running into problem b), usually, this has to do with user, ACL and account.

Environment

Release: CNMSPP99000-8.4-Unified Infrastructure Mgmt-Server Pack-- On Prem
Component:

Resolution

1) If we check wasp and portal logs, we would find them full with these error messages:

ERROR [PortalInitAction:111] (4) not found, Received status (4) on response (for sendRcv) for cmd = 'nametoip' name = '/infba01-S3948_domain/infba01-S3948_hub/infba01-S3948/discovery_server'

ERROR [PortalInitAction:111]   at com.firehunter.usm.DataFactory.getDiscoveryStatus(DataFactory.java:7029)

 

  • The above errors tell us that there is something wrong with the address that wasp has of our discovery_server probe.
  • Then, if we open controller's (on the robot where discovery_server probe is running) probe utility (ctrl + p) and run the so-called "nametoip" callback, we will see it returns an error: "Command status: not found".
  • To fix this, we have to access wasp's Raw Configure (ctrl + right-click) and then, within the "ump_common" section, modify our "discovery_server" entry to makes it look like this: discovery_server = discovery_server.
  • After that, if we go back to UMP, we should find the discovery_wizard gear just as it was before:

<Please see attached file for image>

src="/servlet/servlet.FileDownload?file=0150c000004AKF0AAO" alt="discovery working.png" width="631" height="127">

2) If the problem was with some particular user(s) and there was no error message while hovering over the "Inventory" field, then, most likely, there is a problem with the user using an ACL that is linked to an account. 

  • The explanation on this:
  • For users to be able to see discovery wizard, they need to have certain permissions in their ACL (Discovery, Discovery Management):

https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/administering-ca-uim/acl-permissions-list

  • On top of that, the user needs to be a Bus user:

https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/administering-ca-uim/types-of-users

  • LDAP should be transparent here. So, if we have a Bus user, that has an ACL with the required permissions BUT it is linked to an account, that would be like having an Account Contact user, thus, the user would not be able to see discovery wizard.
  • To fix this, we need to go to:
  • Infrastructure Manager: "Security", "Manage Access Control List", select our ACL and click on "Set Account Link...". Then, we would need to chose "<none>" so the user is no longer an Account Contact user, but a Bus user (if it was originally created as a Bus user).

 

 

 

 

Attachments

1558702647042000006926_sktwi1f5rjvs16py5.png get_app
1558702644947000006926_sktwi1f5rjvs16py4.png get_app
1558618528318000006926_sktwi9tkjvsehwyl.png get_app
1558618526392000006926_sktwi9tkjvsehwyk.png get_app