A Transition rule error is being written to the stdlog frequently. What has caused it?
search cancel

A Transition rule error is being written to the stdlog frequently. What has caused it?

book

Article ID: 69254

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

The following error message or a similar one is written to the stdlog frequently. 

domsrvr:wsp 7852 ERROR stc_mgr.c 681 Transition rule [iss_trans:1031] specifies transition from INVALID status [AEUR] to new_status [RE] for tenant [(NULL)] 

What is the cause of error and how do I stop it occurring? 

Environment

CA Service Desk Manager - All Versions. 

Cause

The status specified in a ticket Transition setting does not exist.

e.g. For the following error message, 

05/16 18:49:07.03 <server_name> domsrvr:wsp 7852 ERROR stc_mgr.c 681 Transition rule [iss_trans:1031] specifies transition from INVALID status [AEUR] to new_status [RE] for tenant [(NULL)]

One or more Issue Transitions under 'Service Desk' > 'Issue' > 'Issue Transitions' on [Administration] tab has a Status with the non-existant Status Code, "AEUR". 

 

 

Resolution

Search for the Status Code shown in the error message as "Invalid Status", to confirm whether it exists (in the above case "AEUR"). If it does not, please specify an existing Status to the Transition. 

If you see the error message with for other ticket types transitions, in_trans or cr_trans, check the transition statuses for the other ticket type's (Incident, Request).

Attachments

1558620862499000069254_sktwi1ysjvsbg75v.jpeg get_app