Unlocking user account
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Unlocking user account

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Article ID: 6904

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Updated On:

Products

CA Harvest Software Change Manager - OpenMake Meister CA Harvest Software Change Manager

Issue/Introduction

User account was locked.  When they try to login to Workbench they see this error:

Unable to log into broker <broker name>
E03020540: Your account is locked; you have exceeded the maximum number of the logon failure attempts.

Environment

Harvest Software Change Manager all versions and platforms

Cause

According to the password policy registered with Harvest using the "hppolset" command, if a user tries to login too many times with the wrong password, Harvest will lock the user account.  It must then be unlocked by a Harvest administrator.

Resolution

There are several ways for the Harvest Administrator to unlock a user account that has been locked:

  • The easiest would be for the Harvest Administrator to login to the Administrator Tool and click the "Users Groups" tab.  Locate the user with the locked account in the list, right click and select Properties.  From the Properties window, uncheck the "Locked" checkbox.
  • There is also a command line utility called "husrunlk".  If the Harvest Administrator does not have access to the Windows GUI Administrator Tool, this is an option that can be executed from a computer (Windows, Linux or Unix) that has the Harvest Command Line Utilities installed.  See the Command Line Reference Guide for details about how to execute this command.
  • If it is the Harvest Administrator's account that is locked, a SQL script has been provided that can be executed by the Harvest DBA in order to unlock the Administrator account.  See the Administrator Guide for details about this SQL script.

Additional Information

You can read more about the husrunlk command here: husrunlk Command-Unlock User

You can read more about the HUsrUnlk.sql script here: Administrate Users - Unlock User Accounts

About the "Locked" checkbox on the User Properties window in the Administrator Tool:

This option specifies whether the account is locked out, which means the user will be unable to log on. If the account is currently locked out, this check box is checked and enabled. You can clear the check box to unlock the account. If the account is not locked out, the check box is empty and disabled. You cannot use this option to lock an account. The only way an account can be locked is if the user tries to log on more than the number of logon attempts specified in the Password Policy of Group Policy.