Is X11 library required?