Agent group load Balancing frequency
search cancel

Agent group load Balancing frequency

book

Article ID: 68864

calendar_today

Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

How-To: Modify the Load Balancing frequency and its implication on the server?

Environment

Release: Workload Automation DE (12.x)

Cause

The CPU Monitor polling interval for Load Balancing is set to 300 seconds (5 minutes, by default).

Though the Load Balancing frequency is configurable, the frequency determines the number of Load Balancing messages the server will receive.

 

Resolution

The Load Balancing frequency can be modified from the Desktop Client (Importantly, you need CA Support instruction to change the Advanced Parameter value):

Steps to follow:

  1. Open the Desktop Client, Admin perspective and click "Topology"
  2. Right-click the server instance, and select "Server Instance Parameters"
  3. Click "Internal" and "Show Advanced Parameters" icon
  4. Modify the parameter "*CPU monitors polling interval for load balancing (seconds)" Default value is 300.

 

Additional Information

Reducing the LOAD BALANCING frequency will increase the load on the DE Server as all the Agents of the specific "Agent Group" will keep sending the "LOAD BALANCING" message in the reduced frequency.  This means that the DE Server has to process more number of "LOAD BALANCING" messages apart from the regular workload processing. If the server is already being loaded with heavy workload processing, adding more "LOAD BALANCING" messages may cause little delay in the actual workload processing.

Note: Some users may experience startup delay of DE (dSeries) when large number of CPU messages are processed by manager.