Agents disappearing from inventory
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Agents disappearing from inventory

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Article ID: 68521

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Updated On:

Products

CA Client Automation CA Client Automation - IT Client Manager

Issue/Introduction

Some machines disappears from DSM Explorer inventory. E.g.: The pc001 was redeployed often, however this problem persists. It continues disappearing and does not exist any policy of deletion.

Environment

Client Automation - All versions

 

 

Cause

Client Automation's machines are considered unique by their HostUUID, if there’re cloned machines, some of them might have the same HostUUID.

This will cause that when one of those machines gets registered to its Scalability Server, the other Agent with same HostUUID will disappear, since it's not unique and only one machine can exist per HostUUID.

Resolution

Apply the following procedures on the agents that are disappearing:

  1. CAF stop
  2. Locate the hostuuid in the following registry path:

HKLM\Software\Wow6432Node\Computer Associates\Hostuuid\hostuuid

  1. Delete hostuuid
  2. CAFstart

Additional Information

This will give the machine a new HostUUID and it won't match any other machine.

A common cause of this behavior is, if a Ghost Image (or similar) is used to install Agents, when this Image comes with the Agent pre-installed and with am already given HostUUID, that code will be replicated on all Agents that used this image as template.