Cannot Update large Transactions from Image Validation Mode
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Cannot Update large Transactions from Image Validation Mode

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Article ID: 68508

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder)

Issue/Introduction

We captured around 3600 transactions using Image Validation mode and clicked on "Update Button" on the "View Session/Tracking Information" window. 

The browser hangs for some time after that and then shows a blank page. We tried this multiple times and see the same issue. 

 

Environment

All supported DevTest Versions

Component: ITKOVS

Cause

The large number of transaction being processed in the update means that the default time-out of 60 seconds is not sufficient to allow them all to be processed. This is evidenced by the time out messages that are present in the logs when performing this update.

Resolution

Adding the below property to the .vmoptions file for the relevant Virtual Service Environment (VSE) will increase the time-out and allow the update to complete

-Dlisa.net.timeout.ms=420000

Please note that the VSE will need to be restarted following this change.