Service Desk Manager - Rejecting duplicate session ID as it already exists in session_log

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Article ID: 6848

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Duplicate session id in session_log table

We may see this error message in the stdlog

<<

boplgin 13424 SIGNIFICANT bplaccess.c 7521 Rejecting duplicate session ID 576895399 as it already exists in session_log

>>

 

Cause

Service Desk generate session id randomly. When the session_log table is very big, we have the duplicate error. The application nee to retry to connect and a new session id will be used.

This behavior impact the login performance.

Environment

Service Desk 12.9 and 14.1

Service Desk Manager 17.x

Resolution

The archive/purge is needed to delete old rows not any more needed.



Reduce the rows in session_log table resolve the duplicate session_id and also positively impact on the performance for login process updating smaller session_log table.



 



Follow this tecdoc to archive and purge the session_log table
https://comm.support.ca.com/kb/archive-and-purge-sessionlog/kb000046910

Additional Information

Information stored in the session_log table
https://comm.support.ca.com/kb/archive-and-purge-sessionlog/kb000046910