DB00501E - OPEN ERROR - RETURN CODE 74 (081) CXX=xxxxxxx (aaannnnn)
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DB00501E - OPEN ERROR - RETURN CODE 74 (081) CXX=xxxxxxx (aaannnnn)

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Article ID: 6803

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Updated On:

Products

Datacom Datacom/AD Datacom/DB

Issue/Introduction

When trying a function against my MUF, received the following errors:

DB00501E - OPEN ERROR - RETURN CODE 74 (081) CXX=<cxxname> (aaannnnn) MUFNAME=<mufname>

...where the CXXname and MUFname are those of the MUF, and where aaa is the area name for nnnnn, which is the database ID. Together, aaannnnn is the DDname used in the MUF for the database file.

Also received error messages:

DB01401E - MVS DYNAMIC ALLOCATION ERROR, DDNAME=aaannnnn, R15=4, ERROR=1708, INFO=0002
DB01417E - DYNALLOC ERROR, aaannnnn <dsn for this file> 

 

 

Cause

RC 74(081) is a dynamic allocation error.

To find out more information on the RC 74(081) error,  check the Datacom MUF for error message DB01401E which will give more information on the error and which file could not be allocated.

DB01401E MVS DYNAMIC ALLOCATION ERROR, DDNAME=aaannnnn, R15=n, ERROR=eeee, INFO=iiii

The ERROR= value (eeee) is obtained from the DYNALLOC S99ERROR

The  INFO= value (iiii) is obtained from the DYNALLOC S99INFO

The following is a list of the common SVC99 or DYNALLOC Error Reason Codes:             

0210 - Requested data set unavailable.  The dataset is allocated to another job and it's usage attribute conflicts with this request.  (dsname allocation)                                

0214 - Unit not available.                                

0218 - Specified volume or an acceptable volume is not mounted.                                    

0238 - Space unavailable in task I/O table (TIOT)         

17081718172C - LOCATE error. Cannot find dsname in catalog, volume, etc.

0450 - Request caused the limit of concurrent allocations (TIOT) to be exceeded.                             

For a complete list of reason codes, refer to the  z/OS MVS Programming: Authorized Assembler Services Guide and in the section Interpreting DYNALLOC Return Codes

 

Resolution

One of the most common causes for this error is that the database file shown has been deleted from the system catalog. This could be due to a direct delete command, or as a result of the file being migrated and then removed per the migration lifecycle definitions.

Here are the general steps to follow for resolving the Dynamic Allocation Error:

  1. Run the DBUTLTY program with this input command: REPORT AREA=CXX,DBID=nnnnn
  2. Find the "DATA SET NAME"  value for the area aaa
  3. If the DATA SET NAME is not blank, check the z/OS catalog to see if this data set exists or is available from a system/pack backup
  4. If it does not exist, you will need to follow your procedure to allocate and restore the file from a Datacom backup. If the missing file is for an Index area (aaa = IXX), you can allocate a new file and then run a DBUTLTY program to INIT the Index area, followed by a RETIX to rebuild the index from the existing Data area. If you need assistance with this step, please contact Datacom support.

Additional Information

If there are multiple dynamic allocation errors, there could be a problem with the CXX that was used. Please see KB article 434324 for more information about this.

As always, please contact Broadcom support for Datacom if you have further questions.