Unable to Export IME for Identity Manager
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Unable to Export IME for Identity Manager

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Article ID: 67920

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Can't export Identity Manager environment from the management console. Receive following error

The following error(s) occurred: 

Permission denied 

 

Environment

Release: Identity Manager 14.x running on Linux

Application Server: JBoss / Wildfly

Cause

The reason you are receiving the Permission denied error is because the linux user does not have sudo privileges. In other words when you are trying to export the environment it can't write to the server because the user who ran jboss does not have the correct permissions to do so.

Resolution

Several options are available:

1. Stop the application server and rerun it as root or a user who has sudo privileges. This will allow the user to write to the server and allow you to export the environment.

2. Add the following entry to standalone.sh

cd $JBOSS_HOME

Additional Information

When trying to export the environment from the management console it has to save the zip file to a temporary location on the Linux server running jboss. If the user does not have sudo privileges it will not be able to write to the location and therefore when in the management console it will not export and will result in the "Permission denied" error. You will be able to export the xml files individually still (directory.xml, roles.xml, and advanced settings.xml). The reason you can do this is because this is pulled from memory and doesn't save to a temporary location so the user doesn't need root privileges.