CA Strong Authentication server does not start with backup database
search cancel

CA Strong Authentication server does not start with backup database

book

Article ID: 67862

calendar_today

Updated On:

Products

CA Advanced Authentication CA Strong Authentication CA Risk Authentication

Issue/Introduction

CA Strong Authentication server is not starting up when primary DB is down and only backup DB is up.

I have configured both primary database and secondary database for CA Strong Authentication installation. When primary database is up, the server is starting without problem but when primary database is down and secondary database is up, CA Strong Authentication server is not able to start up.

 

Environment

Component: CA Strong Authentication Server (Arcot WebFort)

Release : 9.x

Cause

The default factory settings of CA Strong Authentication server is to start with Primary DB only. In the startup log you can see the configuration of "StartWithAnyPool" is set as 0 by default.

00WFMAIN - -------------------------------------------------------------------

00WFMAIN - Listing : [arcot/db/dbconfig]

00WFMAIN - -------------------------------------------------------------------

00WFMAIN - arcot/db/dbconfig/DbType..................... : [oracle]

00WFMAIN - arcot/db/dbconfig/EnableBrandLicensing....... : 1

00WFMAIN - arcot/db/dbconfig/StartWithAnyPool........... : 0

00WFMAIN - -------------------------------------------------------------------

Resolution

The configuration parameter "StartWithAnyPool" needs to enabled. This enables CA Strong Authentication to start with the backup database when the primary database is unavailable.

Set/add below parameter in [arcot/db/dbconfig] section of <ARCOT_HOME>/conf/arcotcommon.ini

StartWithAnyPool=1